Install Specific Version

It is possible to switch to an specific version of the RTLS Hub backend if required.

Stop the Running RTLS Hub

Before installing a specific version of the RTLS Hub backend, it is mandatory to stop the running Hub as described previously in the “Run the Simulation in the RTLS Hub” section of this guide.

Pulling specific containers

Open the “docker-compose.yml”file from the extracted bundle package.

../_images/docker_yml.png

Edit the version of the RTLS Hub backend from “latest” to the desired version. For example, here it has been modified to “1.1.4 – 200803444-1c52bf0”.

Similarly, version of RTLS Hub frontend can be adapted accordingly. For example, here it has been modified to “0.4.1”.

../_images/docker_yml_edit.png

To pull the specific version, execute the following command.

docker-compose pull

../_images/docker_compose_pull.png

This will start pulling the specified version from the docker-compose.yml file.

Running the RTLS Hub

Execute the following command to run the pulled RTLS Hub.

docker-compose up -d

../_images/docker_compose_up.png

This will ensure the specific version of the RTLS Hub is running on the machine.